System Requirements

Operating systems

ADSS Server is a JEE 8 application supported on these platforms (ask about support for others). The following 64bit operating systems are supported (32bit on request):

Windows Server 2016, 2012 R2, 2012, 2008 R2
Linux (RedHat 7.x, SuSe, Centos, others)
Solaris 11 (x86 only)

Databases

ADSS Server saves its configuration and transactional data in a database, the following databases are supported:

Microsoft SQL Server 2016, 2014, 2012 (Express, Web Edition or Enterprise)
Azure SQL Database (Database-as-a-service)
Oracle 12c, 11gR2, 11g, 10g
PostgreSQL v9.x, v8.x
MySQL 5.x (Percona and Oracle)

About 1GB of database space is required to store the service logs from 100,000 transactions for each service unless these are regularly auto-archived or customised.

Hardware requirements

A modern multi-core CPU such as the Xeon E3-xxxx or E5-xxxx or E55xx or E56xx or similar are recommended, with 8GB RAM (min 4GB RAM) and 2GB disk space. Additional RAM may be required to power signing or LTANS archive services. Roughly 0.5GB to 1GB of disk space is required to keep the trace logs per 100,000 service transactions.
The database can be run on a separate server if preferred. This is recommended for high performance environments to allow all server resources to be directed to ADSS Server services. For this:
A modern multi-core CPU such as theXeon E3-xxxx or E5-xxxx or E55xx or E56xx or similar are recommended, with 8GB RAM, typically 5-10GB or more of disk space will be required depending on usage and transactional data / log retention requirements.

Client systems (systems sending service requests to ADSS Server)

Any reasonable system. ADSS Client SDK for Java API requires JRE v1.5 or above. ADSS Client SDK for .NET requires Microsoft .NET Framework 4.0 or above.

Operator browsers

The following browsers are supported for ADSS Server Operators:

Google Chrome 30+
Firefox 25+
Edge 38+
Internet Explorer (IE) 9+

Mobile Devices OS

For authorised remote signing, the native apps (iOS and Android) of Go>Sign Mobile will require the following OS versions:

iOS 9.0 or above
Android 6 (Marshmallow) or above

HSMs (optional)

The following Hardware Security Modules are supported:

Gemalto/ SafeNet Luna and ProtectServer HSMs
Thales nShield Solo or Connect HSMs
Utimaco HSMs
Microsoft Azure Key Vault HSM
Amazon AWS Cloud HSM

Optional DMZ proxy machine

A DMZ proxy server can be configured if required. The following DMZ proxy machines are supported:

Windows Server + IIS 8.0 or Apache or IBM HTTP Server
Linux + Apache or IBM HTTP Server

Use a reasonable CPU, 2GB RAM,100 MB disk space

Load balancers

Any commercial Network Load Balancer.

Contact us today with your high-level business needs and we will quickly respond with how we can help
Contact us today with your high-level business needs and we will quickly respond with how we can help